lkml.org 
[lkml]   [2020]   [Sep]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v2 00/11] rtc: rx8010: use regmap instead of i2c smbus API
Date
From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

I want to use this driver on a platform where the i2c controller doesn't
speak SMBUS. This series converts the driver to i2c regmap which can
figure out the correct protocol to use.

The actual conversion happens in patch 10, the rest are just cleanups and
refactoring.

v1 -> v2:
- s/parentheses/brackets/g
- add a patch switching the driver to using the preferred RTC API
- rework the patch removing magic values
- use range_max and range_min instead of manual range checks
- add a patch adding a helper variable in probe() for client->dev
- add a patch using sizeof(*rx8010) instead of sizeof(struct rx8010_data)

--

Alexandre: I believe that the implementation of devm_rtc_allocate_device()
and rtc_register_device() is wrong as I explained under the previous
version of this series. I'll send an RFC that reworks this part soon.

Bartosz Golaszewski (11):
rtc: rx8010: remove unnecessary brackets
rtc: rx8010: consolidate local variables of the same type
rtc: rx8010: use tabs instead of spaces for code formatting
rtc: rx8010: rename ret to err in rx8010_set_time()
rtc: rx8010: don't use magic values for time buffer length
rtc: rx8010: drop unnecessary initialization
rtc: rx8010: use a helper variable for client->dev in probe()
rtc: rx8010: prefer sizeof(*val) over sizeof(struct type_of_val)
rtc: rx8010: switch to using the preferred RTC API
rtc: rx8010: convert to using regmap
rtc: rx8010: use range checking provided by core RTC code

drivers/rtc/rtc-rx8010.c | 306 +++++++++++++++++----------------------
1 file changed, 131 insertions(+), 175 deletions(-)

--
2.26.1

\
 
 \ /
  Last update: 2020-09-10 15:08    [W:0.666 / U:0.220 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site