lkml.org 
[lkml]   [2020]   [Sep]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v2 0/9] THP iomap patches for 5.10
Date
These patches are carefully plucked from the THP series.  I would like
them to hit 5.10 to make the THP patchset merge easier. Some of these
are just generic improvements that make sense on their own terms, but
the overall intent is to support THPs in iomap.

v2:
- Move the call to flush_dcache_page (Christoph)
- Clarify comments (Darrick)
- Rename read_count to read_bytes_pending (Christoph)
- Rename write_count to write_bytes_pending (Christoph)
- Restructure iomap_readpage_actor() (Christoph)
- Change return type of the zeroing functions from loff_t to s64

Matthew Wilcox (Oracle) (9):
iomap: Fix misplaced page flushing
fs: Introduce i_blocks_per_page
iomap: Use kzalloc to allocate iomap_page
iomap: Use bitmap ops to set uptodate bits
iomap: Support arbitrarily many blocks per page
iomap: Convert read_count to read_bytes_pending
iomap: Convert write_count to write_bytes_pending
iomap: Convert iomap_write_end types
iomap: Change calling convention for zeroing

fs/dax.c | 13 ++-
fs/iomap/buffered-io.c | 173 +++++++++++++++++-----------------------
fs/jfs/jfs_metapage.c | 2 +-
fs/xfs/xfs_aops.c | 2 +-
include/linux/dax.h | 3 +-
include/linux/pagemap.h | 16 ++++
6 files changed, 96 insertions(+), 113 deletions(-)

--
2.28.0

\
 
 \ /
  Last update: 2020-09-11 01:48    [W:0.361 / U:0.504 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site