lkml.org 
[lkml]   [2020]   [Aug]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] rapidio: fix get device imbalance on error
On Thu, Aug 20, 2020 at 10:44:57PM -0500, George Acosta wrote:
> Fix the imbalance in mport_cdev_open.
> Call put_device in error path to balance the
> refcount that increased by the get_device.
>
> Fixes: e8de370188d0 ("rapidio: add mport char device driver")
> Signed-off-by: George Acosta <acostag.ubuntu@gmail.com>
> ---
> drivers/rapidio/devices/rio_mport_cdev.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/rapidio/devices/rio_mport_cdev.c b/drivers/rapidio/devices/rio_mport_cdev.c
> index c07ceec3c6d4..3b68e00eb40f 100644
> --- a/drivers/rapidio/devices/rio_mport_cdev.c
> +++ b/drivers/rapidio/devices/rio_mport_cdev.c
> @@ -1908,6 +1908,7 @@ static int mport_cdev_open(struct inode *inode, struct file *filp)
> sizeof(struct rio_event) * MPORT_EVENT_DEPTH,
> GFP_KERNEL);
> if (ret < 0) {
> + put_device(&chdev->dev);
> dev_err(&chdev->dev, DRV_NAME ": kfifo_alloc failed\n");
> ret = -ENOMEM;
> goto err_fifo;
> --

If we ever hit this error path then the:

list_add_tail(&priv->list, &chdev->file_list);

needs to be removed from the list as well or it lead to a use after
free. Probably just move the list_add_tail() after the kfifo_alloc()
has succeeded. We need to remove it from the list in mport_cdev_release()
as well...

The error handling in this function is kind of rubbish.
1) Get rid of the out label and return directly (more readable).
1b) Use "return 0;" instead of "retur ret;" for the success path.
2) Name the labels after what they do not where they "come from". In
other words do.

err_priv:
kfree(priv);

3) Create a label to call put_device:

err_device:
put_device(&chdev->dev);

Change all the error paths to use the goto instead of calling
put_device() before the goto.

regards,
dan carpenter

\
 
 \ /
  Last update: 2020-08-21 10:15    [W:0.041 / U:0.308 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site