lkml.org 
[lkml]   [2020]   [Aug]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v7 00/11] Introduce features and debugfs/sysfs entries for MHI
On 2020-08-10 23:26, Manivannan Sadhasivam wrote:
> Hi Bhaumik,
>
> On Mon, Aug 10, 2020 at 03:00:54PM -0700, Bhaumik Bhatt wrote:
>> Save hardware information from BHI.
>> Allow reading and modifying some MHI variables for debug, test, and
>> informational purposes using debugfs.
>> Read values for device specific hardware information to be used by
>> OEMs in
>> factory testing such as serial number and PK hash using sysfs.
>>
>> This set of patches was tested on arm64 and x86.
>>
>
> Sorry for stretching the review so long. Will apply the series to
> mhi-next
> once v5.9-rc1 is out.
>
> Thanks,
> Mani
>
Awesome. Thank you for the thorough review.
>> v7:
>> -Added suggested-by and reviewed-by tags
>> -Fixed nitpick on removal of M3_fast counter as it was unused
>> -Updated sysfs documentation dates and intended kernel version
>> -Fixed minor debugfs formatting by removing an extra newline character
>>
>> v6:
>> -Introduced APIs for allocating and freeing the MHI controller so as
>> to ensure
>> that it is always zero-initialized
>> -Moved gerrits around for counter introduction
>> -Fixed documentation for sysfs
>>
>> v5:
>> -Removed the debug entry to trigger reset and will be addressed in a
>> seperate
>> patch
>> -Added patch bus: mhi: core: Use counters to track MHI device state
>> transitions
>> -Updated helper API to trigger a non-blocking host resume
>> -Minor nitpicks also fixed
>>
>> v4:
>> -Removed bus: mhi: core: Introduce independent voting mechanism patch
>> -Removed bus vote function from debugfs due to independent voting
>> removal
>> -Added helper resume APIs to aid consolidation of spread out code
>> -Added a clean-up patch and a missing host resume in voting API
>>
>> v3:
>> -Add patch to check for pending packets in suspend as a dependency for
>> the
>> independent voting mechanism introduction
>> -Include register dump entry for debugfs to dump MHI, BHI, and BHIe
>> registers
>> -Update commit message for the debugfs patch
>> -Updated Documentation/ABI with the required info for sysfs
>> -Updated debugfs patch to include a new KConfig entry and dependencies
>> -Updated reviewed-by for some patches
>>
>> v2:
>> -Added a new debugfs.c file for specific debugfs entries and code
>> -Updated commit text and addressed some comments for voting change
>> -Made sure sysfs is only used for serial number and OEM PK hash usage
>>
>> Bhaumik Bhatt (11):
>> bus: mhi: core: Remove double occurrence for mhi_ctrl_ev_task()
>> declaration
>> bus: mhi: core: Abort suspends due to outgoing pending packets
>> bus: mhi: core: Use helper API to trigger a non-blocking host resume
>> bus: mhi: core: Trigger host resume if suspended during
>> mhi_device_get()
>> bus: mhi: core: Use generic name field for an MHI device
>> bus: mhi: core: Introduce helper function to check device state
>> bus: mhi: core: Introduce counters to track MHI device state
>> transitions
>> bus: mhi: core: Introduce debugfs entries for MHI
>> bus: mhi: core: Read and save device hardware information from BHI
>> bus: mhi: core: Introduce APIs to allocate and free the MHI
>> controller
>> bus: mhi: core: Introduce sysfs entries for MHI
>>
>> Documentation/ABI/stable/sysfs-bus-mhi | 21 ++
>> MAINTAINERS | 1 +
>> drivers/bus/mhi/Kconfig | 8 +
>> drivers/bus/mhi/core/Makefile | 5 +-
>> drivers/bus/mhi/core/boot.c | 17 +-
>> drivers/bus/mhi/core/debugfs.c | 409
>> +++++++++++++++++++++++++++++++++
>> drivers/bus/mhi/core/init.c | 81 ++++++-
>> drivers/bus/mhi/core/internal.h | 37 ++-
>> drivers/bus/mhi/core/main.c | 27 +--
>> drivers/bus/mhi/core/pm.c | 26 ++-
>> include/linux/mhi.h | 30 ++-
>> 11 files changed, 623 insertions(+), 39 deletions(-)
>> create mode 100644 Documentation/ABI/stable/sysfs-bus-mhi
>> create mode 100644 drivers/bus/mhi/core/debugfs.c
>>
>> --
>> The Qualcomm Innovation Center, Inc. is a member of the Code Aurora
>> Forum,
>> a Linux Foundation Collaborative Project
>>

\
 
 \ /
  Last update: 2020-08-11 19:53    [W:0.160 / U:0.848 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site