lkml.org 
[lkml]   [2020]   [Jul]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] scsi: libcxgbi: use kvzalloc instead of opencoded kzalloc/vzalloc
From
Date
On Sat, 2020-08-01 at 01:10 +0300, Denis Efremov wrote:
>
> On 8/1/20 12:58 AM, Joe Perches wrote:
> > On Sat, 2020-08-01 at 00:55 +0300, Denis Efremov wrote:
> > > Remove cxgbi_alloc_big_mem(), cxgbi_free_big_mem() functions
> > > and use kvzalloc/kvfree instead.
> >
> > Sensible, thanks.
> >
> > > diff --git a/drivers/scsi/cxgbi/libcxgbi.c b/drivers/scsi/cxgbi/libcxgbi.c
> > []
> > > @@ -77,9 +77,9 @@ int cxgbi_device_portmap_create(struct cxgbi_device *cdev, unsigned int base,
> > > {
> > > struct cxgbi_ports_map *pmap = &cdev->pmap;
> > >
> > > - pmap->port_csk = cxgbi_alloc_big_mem(max_conn *
> > > - sizeof(struct cxgbi_sock *),
> > > - GFP_KERNEL);
> > > + pmap->port_csk = kvzalloc(array_size(max_conn,
> > > + sizeof(struct cxgbi_sock *)),
> > > + GFP_KERNEL);
> >
> > missing __GFP_NOWARN
> >
>
> kvmalloc_node adds __GFP_NOWARN internally to kmalloc call
> https://elixir.bootlin.com/linux/v5.8-rc4/source/mm/util.c#L568

Only when there's a fallback, and the fallback does not.


\
 
 \ /
  Last update: 2020-08-01 00:25    [W:0.058 / U:1.008 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site