lkml.org 
[lkml]   [2020]   [Jul]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH 4/6] staging: qlge: qlge_main: Simplify while statements.
    On 2020-07-13 17:50 +0530, Suraj Upadhyay wrote:
    > Simplify while loops into more readable and simple for loops.
    >
    > Signed-off-by: Suraj Upadhyay <usuraj35@gmail.com>
    > ---
    [...]
    > @@ -1824,7 +1821,7 @@ static struct sk_buff *ql_build_rx_skb(struct ql_adapter *qdev,
    > sbq_desc->p.skb = NULL;
    > skb_reserve(skb, NET_IP_ALIGN);
    > }
    > - do {
    > + for (; length > 0; length -= size, i++) {
    > lbq_desc = ql_get_curr_lchunk(qdev, rx_ring);
    > size = min(length, qdev->lbq_buf_size);
    >
    > @@ -1839,7 +1836,7 @@ static struct sk_buff *ql_build_rx_skb(struct ql_adapter *qdev,
    > skb->truesize += size;
    > length -= size;
    > i++;
    > - } while (length > 0);
    > + }

    Looks like length and i modification should be removed from here. But in
    this instance, maybe the original was better anyways.

    Agreed with Dan. At least some of those loops can be converted to "count
    up" loops for a more familiar appearance.
    [unhandled content-type:application/pgp-signature]
    \
     
     \ /
      Last update: 2020-07-14 07:43    [W:2.259 / U:0.272 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site