lkml.org 
[lkml]   [2020]   [Jun]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] rcu/performance: Fix kfree_perf_init() build warning on 32-bit kernels
On Wed, Jun 03, 2020 at 11:11:09AM -0700, Paul E. McKenney wrote:
> On Tue, May 26, 2020 at 09:14:13PM -0400, Joel Fernandes wrote:
> > On Tue, May 26, 2020 at 08:27:44PM +0200, Ingo Molnar wrote:

[ . . . ]

> > > BTW., could we please also rename this code from 'PERF_TEST'/'perf test'
> > > to 'PERFORMANCE_TEST'/'performance test'? At first glance I always
> > > mistakenly believe that it's somehow related to perf, while it isn't. =B-)
> >
> > Would it be better to call it 'RCUPERF_TEST' instead of the
> > 'RCU_PERFORMANCE_TEST' you are proposing? I feel the word 'PERFORMANCE' is
> > too long. Also, 'rcuperf test' instead of the 'rcu performance test' you are
> > proposing. I am Ok with doing it however you and Paul want it though, let me
> > know.
>
> As long as we are bikeshedding the name... How about refscale.c and
> RCU_REF_SCALE_TEST on the one hand and rcuscale.c and RCU_SCALE_TEST on
> the other? That keeps the names reasonably short and does not allude
> to perf at all.

Hearing no objections, I will go with the scale/SCALE names.

Thanx, Paul

\
 
 \ /
  Last update: 2020-06-17 20:06    [W:0.062 / U:1.584 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site