lkml.org 
[lkml]   [2020]   [May]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] xhci: Make debug message consistent with bus and port number
On Thu, May 07, 2020 at 02:17:55PM +0800, Kai-Heng Feng wrote:
> Current xhci debug message doesn't always output bus number, so it's
> hard to figure out it's from USB2 or USB3 root hub.
>
> In addition to that, some port numbers are offset to 0 and others are
> offset to 1. Use the latter to match the USB core.
>
> So use "bus number - port index + 1" to make debug message consistent.
>
> Signed-off-by: Kai-Heng Feng <kai.heng.feng@canonical.com>
> ---
> drivers/usb/host/xhci-hub.c | 41 +++++++++++++++++++++----------------
> 1 file changed, 23 insertions(+), 18 deletions(-)
>
> diff --git a/drivers/usb/host/xhci-hub.c b/drivers/usb/host/xhci-hub.c
> index f37316d2c8fa..83088c262cc4 100644
> --- a/drivers/usb/host/xhci-hub.c
> +++ b/drivers/usb/host/xhci-hub.c
> @@ -1241,7 +1241,8 @@ int xhci_hub_control(struct usb_hcd *hcd, u16 typeReq, u16 wValue,
> temp = readl(ports[wIndex]->addr);
> /* Disable port */
> if (link_state == USB_SS_PORT_LS_SS_DISABLED) {
> - xhci_dbg(xhci, "Disable port %d\n", wIndex);
> + xhci_dbg(xhci, "Disable port %d-%d\n",
> + hcd->self.busnum, wIndex + 1);

Shouldn't xhci_dbg() show the bus number already? If not, please fix
that up there instead of having to add it to all messages "by hand".

thanks,

greg k-h

\
 
 \ /
  Last update: 2020-05-07 08:45    [W:0.086 / U:8.772 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site