lkml.org 
[lkml]   [2020]   [May]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] leds: lm355x: avoid enum conversion warning
On Tue, May 05, 2020 at 04:19:17PM +0200, Arnd Bergmann wrote:
> clang points out that doing arithmetic between diffent enums is usually
^ different
> a mistake:
>
> drivers/leds/leds-lm355x.c:167:28: warning: bitwise operation between different enumeration types ('enum lm355x_tx2' and 'enum lm355x_ntc') [-Wenum-enum-conversion]
> reg_val = pdata->pin_tx2 | pdata->ntc_pin;
> ~~~~~~~~~~~~~~ ^ ~~~~~~~~~~~~~~
> drivers/leds/leds-lm355x.c:178:28: warning: bitwise operation between different enumeration types ('enum lm355x_tx2' and 'enum lm355x_ntc') [-Wenum-enum-conversion]
> reg_val = pdata->pin_tx2 | pdata->ntc_pin | pdata->pass_mode;
> ~~~~~~~~~~~~~~ ^ ~~~~~~~~~~~~~~
>
> In this driver, it is intentional, so add a cast to hide the false-positive

Not sure that I would call this a false positive. The warning is correct
that there is a bitwise operation between different enumeration types
but we do not care since we are just using the enumerated type for its
integer value in lieu of a #define VAR value.

> warning. It appears to be the only instance of this warning at the moment.
>
> Fixes: b98d13c72592 ("leds: Add new LED driver for lm355x chips")
> Signed-off-by: Arnd Bergmann <arnd@arndb.de>
> ---
> drivers/leds/leds-lm355x.c | 7 ++++---
> 1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/leds/leds-lm355x.c b/drivers/leds/leds-lm355x.c
> index 11ce05249751..b2eb2e1e9c04 100644
> --- a/drivers/leds/leds-lm355x.c
> +++ b/drivers/leds/leds-lm355x.c
> @@ -164,18 +164,19 @@ static int lm355x_chip_init(struct lm355x_chip_data *chip)
> /* input and output pins configuration */
> switch (chip->type) {
> case CHIP_LM3554:
> - reg_val = pdata->pin_tx2 | pdata->ntc_pin;
> + reg_val = (u32)pdata->pin_tx2 | (u32)pdata->ntc_pin;
> ret = regmap_update_bits(chip->regmap, 0xE0, 0x28, reg_val);
> if (ret < 0)
> goto out;
> - reg_val = pdata->pass_mode;
> + reg_val = (u32)pdata->pass_mode;

Is this cast needed? I don't think there should be warning from going
from an enumerated type to unsigned int.

> ret = regmap_update_bits(chip->regmap, 0xA0, 0x04, reg_val);
> if (ret < 0)
> goto out;
> break;
>
> case CHIP_LM3556:
> - reg_val = pdata->pin_tx2 | pdata->ntc_pin | pdata->pass_mode;
> + reg_val = (u32)pdata->pin_tx2 | (u32)pdata->ntc_pin |
> + (u32)pdata->pass_mode;
> ret = regmap_update_bits(chip->regmap, 0x0A, 0xC4, reg_val);
> if (ret < 0)
> goto out;
> --
> 2.26.0
>

With those comments addressed, feel free to add:

Reviewed-by: Nathan Chancellor <natechancellor@gmail.com>

\
 
 \ /
  Last update: 2020-05-06 04:44    [W:0.122 / U:0.172 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site