lkml.org 
[lkml]   [2020]   [May]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH 1/4] ahci: qoriq: Add platform dependencies
On Thu, May 7, 2020 at 6:30 AM Geert Uytterhoeven
<geert+renesas@glider.be> wrote:
>
> The Freescale QorIQ AHCI SATA controller is only present on Freescale
> Layerscape SoCs. Add platform dependencies to the AHCI_QORIQ config
> symbol, to avoid asking the user about it when configuring a kernel
> without Layerscape support.
>
> Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>

Hi Jens,

Are you applying this patches? I can also apply it with your ACK.

Regards,
Leo
> ---
> drivers/ata/Kconfig | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/ata/Kconfig b/drivers/ata/Kconfig
> index 05ecdce1b702cf8b..d9e66b37acd1862a 100644
> --- a/drivers/ata/Kconfig
> +++ b/drivers/ata/Kconfig
> @@ -264,6 +264,7 @@ config AHCI_XGENE
> config AHCI_QORIQ
> tristate "Freescale QorIQ AHCI SATA support"
> depends on OF
> + depends on SOC_LS1021A || ARCH_LAYERSCAPE || COMPILE_TEST
> select SATA_HOST
> help
> This option enables support for the Freescale QorIQ AHCI SoC's
> --
> 2.17.1
>

\
 
 \ /
  Last update: 2020-05-22 23:30    [W:0.051 / U:9.916 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site