lkml.org 
[lkml]   [2020]   [Apr]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/3] staging: vt6656: Use define instead of magic number for tx_rate
On Sat, Apr 04, 2020 at 04:13:59PM +0200, Oscar Carter wrote:
> Use the define RATE_11M present in the file "device.h" instead of the
> magic number 3. So the code is more clear.
>
> Signed-off-by: Oscar Carter <oscar.carter@gmx.com>
> Reviewed-by: Dan Carpenter <dan.carpenter@oracle.com>
> ---
> drivers/staging/vt6656/baseband.c | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/staging/vt6656/baseband.c b/drivers/staging/vt6656/baseband.c
> index 3e4bd637849a..a785f91c1566 100644
> --- a/drivers/staging/vt6656/baseband.c
> +++ b/drivers/staging/vt6656/baseband.c
> @@ -24,6 +24,7 @@
>
> #include <linux/bits.h>
> #include <linux/kernel.h>
> +#include "device.h"
> #include "mac.h"
> #include "baseband.h"
> #include "rf.h"
> @@ -141,7 +142,7 @@ unsigned int vnt_get_frame_time(u8 preamble_type, u8 pkt_type,
>
> rate = (unsigned int)vnt_frame_time[tx_rate];
>
> - if (tx_rate <= 3) {
> + if (tx_rate <= RATE_11M) {
> if (preamble_type == 1)
> preamble = 96;
> else
> --
> 2.20.1

This doesn't apply to my tree :(

\
 
 \ /
  Last update: 2020-04-06 16:23    [W:0.089 / U:0.840 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site