lkml.org 
[lkml]   [2020]   [Apr]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH] rtw88: Add delay on polling h2c command status bit
Date
Kai-Heng Feng <kai.heng.feng@canonical.com> writes:

>> On Apr 6, 2020, at 20:17, Kalle Valo <kvalo@codeaurora.org> wrote:
>>
>> Kai-Heng Feng <kai.heng.feng@canonical.com> writes:
>>
>>> --- a/drivers/net/wireless/realtek/rtw88/hci.h
>>> +++ b/drivers/net/wireless/realtek/rtw88/hci.h
>>> @@ -253,6 +253,10 @@ rtw_write8_mask(struct rtw_dev *rtwdev, u32
>>> addr, u32 mask, u8 data)
>>> rtw_write8(rtwdev, addr, set);
>>> }
>>>
>>> +#define rr8(addr) rtw_read8(rtwdev, addr)
>>> +#define rr16(addr) rtw_read16(rtwdev, addr)
>>> +#define rr32(addr) rtw_read32(rtwdev, addr)
>>
>> For me these macros reduce code readability, not improve anything. They
>> hide the use of rtwdev variable, which is evil, and a name like rr8() is
>> just way too vague. Please keep the original function names as is.
>
> The inspiration is from another driver.
> readx_poll_timeout macro only takes one argument for the op.
> Some other drivers have their own poll_timeout implementation,
> and I guess it makes sense to make one specific for rtw88.

I'm not even understanding the problem you are tying to fix with these
macros. The upstream philosopyhy is to have the source code readable and
maintainable, not to use minimal number of characters. There's a reason
why we don't name our functions a(), b(), c() and so on.

--
https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches

\
 
 \ /
  Last update: 2020-04-06 15:25    [W:0.928 / U:0.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site