lkml.org 
[lkml]   [2020]   [Apr]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] xfs: Use the correct style for SPDX License Identifier
On Mon, Apr 27, 2020 at 10:41:58AM -0700, Joe Perches wrote:
> On Mon, 2020-04-27 at 19:29 +0200, Greg Kroah-Hartman wrote:
> > On Mon, Apr 27, 2020 at 08:56:18AM -0700, Darrick J. Wong wrote:
> > > On Sat, Apr 25, 2020 at 07:05:09PM +0530, Nishad Kamdar wrote:
> > > > This patch corrects the SPDX License Identifier style in
> > > > header files related to XFS File System support.
> > > > For C header files Documentation/process/license-rules.rst
> > > > mandates C-like comments (opposed to C source files where
> > > > C++ style should be used).
> > > >
> > > > Changes made by using a script provided by Joe Perches here:
> > > > https://lkml.org/lkml/2019/2/7/46.
> []
> > > > diff --git a/fs/xfs/libxfs/xfs_ag_resv.h b/fs/xfs/libxfs/xfs_ag_resv.h
> []
> > > > @@ -1,4 +1,4 @@
> > > > -// SPDX-License-Identifier: GPL-2.0+
> > > > +/* SPDX-License-Identifier: GPL-2.0+ */
> > >
> > > I thought we were supposed to use 'GPL-2.0-or-newer' because 'GPL-2.0+'
> > > is deprecated in some newer version of the SPDX standard?
> > >
> > > <shrug>
> >
> > The kernel follows the "older" SPDX standard, but will accept either,
> > it's up to the author. It is all documented in LICENSES/ if people
> > really want to make sure.
>
> I think the kernel should prefer the "newer" SPDX standard
> for any/all changes to these lines.
> ---
> LICENSES/preferred/GPL-2.0 | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/LICENSES/preferred/GPL-2.0 b/LICENSES/preferred/GPL-2.0
> index ff0812..c50f93 100644
> --- a/LICENSES/preferred/GPL-2.0
> +++ b/LICENSES/preferred/GPL-2.0
> @@ -8,13 +8,13 @@ Usage-Guide:
> tag/value pairs into a comment according to the placement
> guidelines in the licensing rules documentation.
> For 'GNU General Public License (GPL) version 2 only' use:
> - SPDX-License-Identifier: GPL-2.0
> - or
> SPDX-License-Identifier: GPL-2.0-only
> + or the deprecated alternative
> + SPDX-License-Identifier: GPL-2.0
> For 'GNU General Public License (GPL) version 2 or any later version' use:
> - SPDX-License-Identifier: GPL-2.0+
> - or
> SPDX-License-Identifier: GPL-2.0-or-later
> + or the deprecated alternative
> + SPDX-License-Identifier: GPL-2.0+
> License-Text:

At the moment, I do not, as the current ones are not "depreciated" at
all.

thanks,

greg k-h

\
 
 \ /
  Last update: 2020-04-27 19:46    [W:0.053 / U:2.424 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site