lkml.org 
[lkml]   [2020]   [Apr]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 07/10] EDAC/ghes: Cleanup struct ghes_edac_dimm_fill, rename it to ghes_dimm_fill
On Wed, Apr 22, 2020 at 01:58:11PM +0200, Robert Richter wrote:
> The struct is used to store temporary data for the dmidecode callback.
> Clean this up a bit:
>
> 1) Rename member count to index since this is what it is used for.
>
> 2) Move code close to ghes_edac_dmidecode() where it is used.
>
> 3) While at it, use edac_get_dimm_by_index().
>
> Signed-off-by: Robert Richter <rrichter@marvell.com>
> ---
> drivers/edac/ghes_edac.c | 24 ++++++++++++------------
> 1 file changed, 12 insertions(+), 12 deletions(-)

Ok except the commit title is wrong. And yes, pls keep it "dimm_fill" -
short and sweet and without yet another "ghes" in the name. :)

Thx.

--
Regards/Gruss,
Boris.

https://people.kernel.org/tglx/notes-about-netiquette

\
 
 \ /
  Last update: 2020-04-27 16:01    [W:0.266 / U:2.840 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site