lkml.org 
[lkml]   [2020]   [Apr]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH V8 09/11] fs: Introduce DCACHE_DONTCACHE
On Wed, Apr 15, 2020 at 11:01:53AM +0200, Jan Kara wrote:
> On Tue 14-04-20 23:45:21, ira.weiny@intel.com wrote:
> > From: Ira Weiny <ira.weiny@intel.com>
> >
> > DCACHE_DONTCACHE indicates a dentry should not be cached on final
> > dput().
> >
> > Also add a helper function which will flag I_DONTCACHE as well ad
> > DCACHE_DONTCACHE on all dentries point to a specified inode.
>
> I think this sentence needs more work :). Like: Also add a helper function
> which will mark the inode with I_DONTCACHE flag and also mark all dentries
> pointing to a specified inode as DCACHE_DONTCACHE.
>
> >
> > Signed-off-by: Ira Weiny <ira.weiny@intel.com>
> >
> > ---
> > Changes from V7:
> > new patch
> > ---
> > fs/dcache.c | 4 ++++
> > fs/inode.c | 15 +++++++++++++++
> > include/linux/dcache.h | 2 ++
> > include/linux/fs.h | 1 +
> > 4 files changed, 22 insertions(+)
>
> ...
>
> > diff --git a/fs/inode.c b/fs/inode.c
> > index 93d9252a00ab..b8b1917a324e 100644
> > --- a/fs/inode.c
> > +++ b/fs/inode.c
> > @@ -1526,6 +1526,21 @@ int generic_delete_inode(struct inode *inode)
> > }
> > EXPORT_SYMBOL(generic_delete_inode);
> >
> > +void flag_inode_dontcache(struct inode *inode)
>
> mark_inode_dontcache?

That works.

>
> > +{
> > + struct dentry *dent;
>
> This is really nitpicking but dentry variables are usually called 'de' or
> 'dentry' :)

Easy change. done.

>
> > +
> > + rcu_read_lock();
>
> I don't think this list is safe to traverse under RCU. E.g.
> dentry_unlink_inode() does hlist_del_init(&dentry->d_u.d_alias). Usually,
> we traverse this list under inode->i_lock protection AFAICS.

Ah... not sure where I got that. I thought I found this locked with rcu
somewhere but I obviously got confused. And I did not even use the rcu version
of the list iterator... :-(

I'll clean it up, thanks for the review,
Ira

>
> Honza
>
> > + hlist_for_each_entry(dent, &inode->i_dentry, d_u.d_alias) {
> > + spin_lock(&dent->d_lock);
> > + dent->d_flags |= DCACHE_DONTCACHE;
> > + spin_unlock(&dent->d_lock);
> > + }
> > + rcu_read_unlock();
> > + inode->i_state |= I_DONTCACHE;
> > +}
> > +EXPORT_SYMBOL(flag_inode_dontcache);
> > +
> > /*
> > * Called when we're dropping the last reference
> > * to an inode.
> --
> Jan Kara <jack@suse.com>
> SUSE Labs, CR

\
 
 \ /
  Last update: 2020-04-16 06:56    [W:0.121 / U:0.172 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site