lkml.org 
[lkml]   [2020]   [Mar]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/2] KVM: x86: VMX: rename 'kvm_area' to 'vmxon_region'
On Thu, Mar 05, 2020 at 04:58:35PM +0100, Vitaly Kuznetsov wrote:
> Sean Christopherson <sean.j.christopherson@intel.com> writes:
>
> > Super nit: can I convince you to use "KVM: VMX:" instead of "KVM: x86: VMX:"?
> >
> > $ glo | grep -e "KVM: x86: nVMX" -e "KVM: x86: VMX:" | wc -l
> > 8
> > $ glo | grep -e "KVM: nVMX" -e "KVM: VMX:" | wc -l
> > 1032
> >
> > I'm very conditioned to scan for "KVM: *VMX:", e.g. I was about to complain
> > that this used the wrong scope :-) And in the event that Intel adds a new
> > technology I'd like to be able to use "KVM: Intel:" and "KVM: ***X:"
> > instead of "KVM: x86: Intel:" and "KVM: x86: Intel: ***X:" for code that is
> > common to Intel versus specific to a technology.
>
> What if someone else adds VMX instead? :-)

I never said it was a _good_ plan :-D

\
 
 \ /
  Last update: 2020-03-05 17:01    [W:0.033 / U:6.736 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site