lkml.org 
[lkml]   [2020]   [Mar]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH V2 0/2] Add support for WLED5
Date
Currently, WLED driver supports only WLED4 peripherals that is present
on pmi8998 and pm660L. This patch series converts the existing WLED4
bindings from .txt to .yaml format and adds the support for WLED5 peripheral
that is present on PM8150L.

PM8150L WLED supports the following.
- Two modulators and each sink can use any of the modulator
- Multiple CABC selection options
- Multiple brightness width selection (12 bits to 15 bits)

Changes from V1:
- Rebased on top of the below commit.
backlight: qcom-wled: Fix unsigned comparison to zero

Kiran Gunda (2):
backlight: qcom-wled: convert the wled bindings to .yaml format
backlight: qcom-wled: Add support for WLED5 peripheral in PM8150L

.../bindings/leds/backlight/qcom-wled.txt | 154 -------
.../bindings/leds/backlight/qcom-wled.yaml | 223 ++++++++++
drivers/video/backlight/qcom-wled.c | 459 ++++++++++++++++++---
3 files changed, 634 insertions(+), 202 deletions(-)
delete mode 100644 Documentation/devicetree/bindings/leds/backlight/qcom-wled.txt
create mode 100644 Documentation/devicetree/bindings/leds/backlight/qcom-wled.yaml

--
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
a Linux Foundation Collaborative Project

\
 
 \ /
  Last update: 2020-03-04 14:11    [W:0.042 / U:5.236 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site