lkml.org 
[lkml]   [2020]   [Mar]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 1/3] KVM: x86: introduce kvm_mmu_invalidate_gva
From
Date
On 28/03/20 19:26, Sean Christopherson wrote:
>> + if (mmu != &vcpu->arch.guest_mmu) {
> Doesn't need to be addressed here, but this is not the first time in this
> series (the large TLB flushing series) that I've struggled to parse
> "guest_mmu". Would it make sense to rename it something like nested_tdp_mmu
> or l2_tdp_mmu?
>
> A bit ugly, but it'd be nice to avoid the mental challenge of remembering
> that guest_mmu is in play if and only if nested TDP is enabled.

No, it's not ugly at all. My vote would be for shadow_tdp_mmu.

Paolo

\
 
 \ /
  Last update: 2020-03-30 12:46    [W:0.094 / U:3.344 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site