lkml.org 
[lkml]   [2020]   [Mar]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v5] m68k: Replace setup_irq() by request_irq()
From
Date
Hi Afzal,

On 4/3/20 11:37 am, afzal mohammed wrote:
> Hi Greg,
>
> On Mon, Mar 02, 2020 at 11:32:53AM +1000, Greg Ungerer wrote:
>
>> I have retested and everything works as expected, so:
>>
>> Tested-by: Greg Ungerer <gerg@linux-m68k.org>
>>
>> I have applied this to the m68knommu git tree, for next branch.
>
> Thanks
>
>>> void hw_timer_init(irq_handler_t handler)
>>> {
>>> + int r;
>>
>> You used 'r' here as the error return value holder.
>> But in the previous cases you used 'ret'.
>> I would have used the same name everywhere ('ret' probably being the
>> most commonly used in the kernel).
>
> That was a circus to dodge 80 char limit, i did think about it while
> making the changes whether to do or not. If 'ret' is used request_irq()
> line had to be split to two, slightly affecting the readability and
> since 'r' was a local variable (though conventionally 'ret' or 'err'
> is used) went ahead that way. Even if 're' is used as the local
> variable, it would be 81 chars ;)
>
> Let me know if you want to change it.

Understand. No, no need to change it.

Regards
Greg


> Regards
> afzal
>
>>> - setup_irq(MCF_IRQ_TIMER, &mcfslt_timer_irq);
>>> + r = request_irq(MCF_IRQ_TIMER, mcfslt_tick, IRQF_TIMER, "timer", NULL);
>>> + if (r) {
>>> + pr_err("Failed to request irq %d (timer): %pe\n", MCF_IRQ_TIMER,
>>> + ERR_PTR(r));
>>> + }

\
 
 \ /
  Last update: 2020-03-04 02:40    [W:0.056 / U:0.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site