lkml.org 
[lkml]   [2020]   [Mar]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: modpost Module.symver handling is broken in 5.6.0-rc7
Date
From: Jessica Yu
> Sent: 26 March 2020 16:51
> +++ David Laight [26/03/20 16:25 +0000]:
> >Something is currently broken in modpost.
> >I'm guessing it is down to the recent patch that moved the
> >namespace back to the end of the line.
> >
> >I'm building 2 'out of tree' modules that have a symbol dependency.
> >When I build the 2nd module I get ERROR "symbol" undefined message.
> >
> >If I flip the order of the fields in Module.symver to the older order
> >and link with modpost from 5.4.0-rc7 (which I happen to have lurking)
> >it all works fine.
> >
> >Note that I'm using a named namespace, not the default one
> >that is the full path of the module.
> >
> >I'll dig in a little further.
>
> [ Adding more people to CC ]
>
> Hi David,
>
> Could you provide some more details about how I can reproduce the
> issue? As I understand it, you have two out-of-tree modules, and one
> has a symbol dependency on the second? Pasting the modpost error
> messages helps too.

Ok, I've found out what broke it.
Was actually the removal of the code that parsed Module.symvers
from the current directory (which happened for 5.5.0-rc0).

Took some digging and printfs in modpost to find what wasn't happening.

David

-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)

\
 
 \ /
  Last update: 2020-03-26 18:06    [W:0.042 / U:11.320 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site