lkml.org 
[lkml]   [2020]   [Mar]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: tegra124-jetson-tk1: sata doesnt work since 5.2
On Thu, Mar 19, 2020 at 08:55:38AM +0100, Nicolas Chauvet wrote:
> Le jeu. 19 mars 2020 à 08:44, LABBE Corentin <clabbe@baylibre.com> a écrit :
> >
> > Hello
> >
> > sata doesnt work on tegra124-jetson-tk1 on next and master and at least since 5.2 (but 5.1 works).
> > [ 0.492810] +5V_SATA: supplied by +5V_SYS
> > [ 0.493230] +12V_SATA: supplied by +VDD_MUX
> > [ 2.088675] tegra-ahci 70027000.sata: 70027000.sata supply ahci not found, using dummy regulator
> > [ 2.097643] tegra-ahci 70027000.sata: 70027000.sata supply phy not found, using dummy regulator
> > [ 3.314776] tegra-ahci 70027000.sata: 70027000.sata supply ahci not found, using dummy regulator
> > [ 3.323658] tegra-ahci 70027000.sata: 70027000.sata supply phy not found, using dummy regulator
> > [ 5.236964] tegra-ahci 70027000.sata: 70027000.sata supply ahci not found, using dummy regulator
> > [ 5.245867] tegra-ahci 70027000.sata: 70027000.sata supply phy not found, using dummy regulator
> > [ 5.254706] tegra-ahci 70027000.sata: 70027000.sata supply target not found, using dummy regulator
> > [ 5.310270] phy phy-sata.6: phy poweron failed --> -110
> > [ 5.315604] tegra-ahci 70027000.sata: failed to power on AHCI controller: -110
> > [ 5.323022] tegra-ahci: probe of 70027000.sata failed with error -110
> > [ 35.694269] +5V_SATA: disabling
> > [ 35.697438] +12V_SATA: disabling
>
> It looks strange, because (on same device) , I have sata working as
> appropriate, but ethernet fails with me.
> https://bugzilla.kernel.org/show_bug.cgi?id=206217
>
> It might worth to have another report.
>

Hello

Mine has ethernet works well. But I hit many problem with it and older kernel.
Perhaps the 5.1.21, were I am stuck, does not have it.

Anyway, the tegra of kerneci has the same SATA problem.
https://storage.kernelci.org/next/master/next-20200325/arm/multi_v7_defconfig+CONFIG_SMP=n/gcc-8/lab-baylibre/boot-tegra124-jetson-tk1.txt

Maintainers, any idea on this sata issue ?

Regards

\
 
 \ /
  Last update: 2020-03-25 14:40    [W:0.067 / U:28.200 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site