lkml.org 
[lkml]   [2020]   [Mar]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] Documentation/changes: Raise minimum supported binutils version to 2.23
On Tue, Mar 24, 2020 at 09:37:13AM -0700, Linus Torvalds wrote:
> On Tue, Mar 24, 2020 at 9:28 AM Borislav Petkov <bp@alien8.de> wrote:
> >
> > Are you or Kees going to deal with any fallout from upping the binutils
> > version, rushed in in the last week before the merge window?
>
> I think it's ok. It's not going to cause any _subtle_ failures, it's
> going to cause very clear "oh, now it doesn't build" errors.
>
> No?
>
> And binutils 2.23 is what, 7+ years old by now and apparently had
> known failure cases too.
>
> But if there are silent and subtle failures, that might be a reason to
> be careful. Are there?

FWIW, I have plenty of other hills to die on, so I have no urgency on
this change. I actually thought it had already happened, since it was
brought up a while ago. :) I am just excited to see it happen since it
unblocks other work I've been touching. As long as it's "eventually",
I don't care when. :)

--
Kees Cook

\
 
 \ /
  Last update: 2020-03-24 18:53    [W:0.071 / U:3.256 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site