lkml.org 
[lkml]   [2020]   [Mar]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH 2/2] media: Remove VIDEO_DEV unneeded dependency
Date
Enable VIDEO_DEV (which compiles Video4Linux core)
when MEDIA_SUPPORT is selected. This is needed, in order
to be able to enable devices such as stateless codecs.

Signed-off-by: Ezequiel Garcia <ezequiel@collabora.com>
---
drivers/media/Kconfig | 2 --
1 file changed, 2 deletions(-)

diff --git a/drivers/media/Kconfig b/drivers/media/Kconfig
index b36a41332867..7de472ad07a2 100644
--- a/drivers/media/Kconfig
+++ b/drivers/media/Kconfig
@@ -93,13 +93,11 @@ source "drivers/media/mc/Kconfig"

#
# Video4Linux support
-# Only enables if one of the V4L2 types (ATV, webcam, radio) is selected
#

config VIDEO_DEV
tristate
depends on MEDIA_SUPPORT
- depends on MEDIA_CAMERA_SUPPORT || MEDIA_ANALOG_TV_SUPPORT || MEDIA_RADIO_SUPPORT || MEDIA_SDR_SUPPORT
default y

config VIDEO_V4L2_SUBDEV_API
--
2.26.0.rc2
\
 
 \ /
  Last update: 2020-03-23 22:11    [W:0.326 / U:2.268 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site