[lkml]   [2020]   [Mar]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v4 2/2] mm/page_alloc: integrate classzone_idx and high_zoneidx
On 03/23/20 at 01:49pm, wrote:
> From: Joonsoo Kim <>
> classzone_idx is just different name for high_zoneidx now.
> So, integrate them and add some comment to struct alloc_context
> in order to reduce future confusion about the meaning of this variable.
> The accessor, ac_classzone_idx() is also removed since it isn't needed
> after integration.
> In addition to integration, this patch also renames high_zoneidx
> to highest_zoneidx since it represents more precise meaning.
> Signed-off-by: Joonsoo Kim <>

The patch looks good, and did the basic test after applying this patch
series. FWIW:

Reviewed-by: Baoquan He <>

 \ /
  Last update: 2020-03-23 08:11    [W:0.069 / U:8.236 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site