lkml.org 
[lkml]   [2020]   [Mar]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3 5/5] platform/x86: intel_pmc_core: fix: Make pmc_core_lpm_display() generic for platforms that support sub-states
On Sun, Mar 01, 2020 at 12:44:26PM -0800, Gayatri Kammela wrote:
> Currently pmc_core_lpm_display() uses array of struct pointers i.e.,
> tgl_lpm_maps for Tiger Lake directly to iterate through and to get the
> number of status/live status registers which is hardcoded and cannot
> be re-used for future platforms that support sub-states. To maintain
> readability, make pmc_core_lpm_display() generic, so that it can re-used
> for future platforms.

My comments below.

...

> +static int pmc_core_lpm_get_arr_size(const struct pmc_bit_map **maps)
> +{
> + int idx, arr_size = 0;

And why do you need arr_size variable at all?

> +
> + for (idx = 0; maps[idx]; idx++)
> + arr_size++;
> +
> + return arr_size;
> +}

...

> - int index, idx, len = 32, bit_mask;
> + int index, idx, bit_mask, len = 32;

What's the point of shuffling this?

> + int arr_size = pmc_core_lpm_get_arr_size(maps);

This would be better in a split manner, i.e.

int arr_size;

...

arr_size = ...;

...

> + lpm_regs = kmalloc_array(arr_size, sizeof(*lpm_regs), GFP_KERNEL);
> + if(!lpm_regs)

> + goto err;

There is no point to have the label. Simple return will work.

> - for (index = 0; tgl_lpm_maps[index]; index++) {
> + for (index = 0; maps[index]; index++) {

Why not to reuse arr_size here?

> lpm_regs[index] = pmc_core_reg_read(pmcdev, offset);
> offset += 4;
> }

--
With Best Regards,
Andy Shevchenko


\
 
 \ /
  Last update: 2020-03-02 13:54    [W:0.273 / U:3.688 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site