lkml.org 
[lkml]   [2020]   [Mar]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH net-next 3/7] net: phy: introduce phy_read_mmd_poll_timeout macro
From
Date
On 19.03.2020 17:39, Dejin Zheng wrote:
> it is sometimes necessary to poll a phy register by phy_read_mmd()
> function until its value satisfies some condition. introduce
> phy_read_mmd_poll_timeout() macros that do this.
>
> Signed-off-by: Dejin Zheng <zhengdejin5@gmail.com>
> ---
> include/linux/phy.h | 4 ++++
> 1 file changed, 4 insertions(+)
>
> diff --git a/include/linux/phy.h b/include/linux/phy.h
> index 36d9dea04016..a30e9008647f 100644
> --- a/include/linux/phy.h
> +++ b/include/linux/phy.h
> @@ -24,6 +24,7 @@
> #include <linux/mod_devicetable.h>
> #include <linux/u64_stats_sync.h>
> #include <linux/irqreturn.h>
> +#include <linux/iopoll.h>
>
> #include <linux/atomic.h>
>
> @@ -784,6 +785,9 @@ static inline int __phy_modify_changed(struct phy_device *phydev, u32 regnum,
> */
> int phy_read_mmd(struct phy_device *phydev, int devad, u32 regnum);
>
> +#define phy_read_mmd_poll_timeout(val, cond, sleep_us, timeout_us, args...) \
> + read_poll_timeout(phy_read_mmd, val, cond, sleep_us, timeout_us, args)
> +
> /**
> * __phy_read_mmd - Convenience function for reading a register
> * from an MMD on a given PHY.
>
I'm not fully convinced. Usage of the new macro with its lots of
parameters makes the code quite hard to read. Therefore I'm also
not a big fan of readx_poll_timeout.

Even though I didn't invent it, I prefer the way DECLARE_RTL_COND
is used in the r8169 driver. The resulting code is much better
to read, and in case of a timeout a helpful warning is printed
automatically.

\
 
 \ /
  Last update: 2020-03-19 17:57    [W:0.081 / U:0.300 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site