lkml.org 
[lkml]   [2020]   [Mar]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3 2/6] kselftest: factor out list manipulation to a helper
On Mon, Mar 16, 2020 at 03:56:42PM -0700, Jakub Kicinski wrote:
> Kees suggest to factor out the list append code to a macro,
> since following commits need it, which leads to code duplication.
>
> Suggested-by: Kees Cook <keescook@chromium.org>
> Signed-off-by: Jakub Kicinski <kuba@kernel.org>

Acked-by: Kees Cook <keescook@chromium.org>

-Kees

> ---
> tools/testing/selftests/kselftest_harness.h | 42 ++++++++++++---------
> 1 file changed, 24 insertions(+), 18 deletions(-)
>
> diff --git a/tools/testing/selftests/kselftest_harness.h b/tools/testing/selftests/kselftest_harness.h
> index 5336b26506ab..aaf58fffc8f7 100644
> --- a/tools/testing/selftests/kselftest_harness.h
> +++ b/tools/testing/selftests/kselftest_harness.h
> @@ -631,6 +631,29 @@
> } \
> } while (0); OPTIONAL_HANDLER(_assert)
>
> +/* List helpers */
> +#define __LIST_APPEND(head, item) \
> +{ \
> + /* Circular linked list where only prev is circular. */ \
> + if (head == NULL) { \
> + head = item; \
> + item->next = NULL; \
> + item->prev = item; \
> + return; \
> + } \
> + if (__constructor_order == _CONSTRUCTOR_ORDER_FORWARD) { \
> + item->next = NULL; \
> + item->prev = head->prev; \
> + item->prev->next = item; \
> + head->prev = item; \
> + } else { \
> + item->next = head; \
> + item->next->prev = item; \
> + item->prev = item; \
> + head = item; \
> + } \
> +}
> +
> /* Contains all the information for test execution and status checking. */
> struct __test_metadata {
> const char *name;
> @@ -665,24 +688,7 @@ static int __constructor_order;
> static inline void __register_test(struct __test_metadata *t)
> {
> __test_count++;
> - /* Circular linked list where only prev is circular. */
> - if (__test_list == NULL) {
> - __test_list = t;
> - t->next = NULL;
> - t->prev = t;
> - return;
> - }
> - if (__constructor_order == _CONSTRUCTOR_ORDER_FORWARD) {
> - t->next = NULL;
> - t->prev = __test_list->prev;
> - t->prev->next = t;
> - __test_list->prev = t;
> - } else {
> - t->next = __test_list;
> - t->next->prev = t;
> - t->prev = t;
> - __test_list = t;
> - }
> + __LIST_APPEND(__test_list, t);
> }
>
> static inline int __bail(int for_realz, bool no_print, __u8 step)
> --
> 2.24.1
>

--
Kees Cook

\
 
 \ /
  Last update: 2020-03-17 21:23    [W:0.079 / U:1.636 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site