lkml.org 
[lkml]   [2020]   [Feb]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 5.4 00/90] 5.4.18-stable review
On Wed, Feb 05, 2020 at 03:13:57PM +0000, Greg Kroah-Hartman wrote:
> On Tue, Feb 04, 2020 at 06:37:38AM -0800, Guenter Roeck wrote:
> > On 2/3/20 8:19 AM, Greg Kroah-Hartman wrote:
> > > This is the start of the stable review cycle for the 5.4.18 release.
> > > There are 90 patches in this series, all will be posted as a response
> > > to this one. If anyone has any issues with these being applied, please
> > > let me know.
> > >
> > > Responses should be made by Wed, 05 Feb 2020 16:17:59 +0000.
> > > Anything received after that time might be too late.
> > >
> >
> > Building i386:allyesconfig ... failed
> > Building i386:allmodconfig ... failed
> > --------------
> > Error log:
> > In file included from arch/x86/kernel/pci-dma.c:2:
> > include/linux/dma-direct.h:29:20: error: conflicting types for 'dma_capable'
> > 29 | static inline bool dma_capable(struct device *dev, dma_addr_t addr, size_t size,
> > | ^~~~~~~~~~~
> > In file included from include/linux/dma-direct.h:12,
> > from arch/x86/kernel/pci-dma.c:2:
> > arch/x86/include/asm/dma-direct.h:5:6: note: previous declaration of 'dma_capable' was here
> > 5 | bool dma_capable(struct device *dev, dma_addr_t addr, size_t size);
>
> Ok, I think this is now resolved with a patch that Sasha added.
>
> I have pushed out a -rc4 that _should_ build and boot properly.
>
The i386 build still fails with v5.4.17-99-gbd0c6624a110 (-rc4).

Guenter

\
 
 \ /
  Last update: 2020-02-05 17:24    [W:0.081 / U:0.852 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site