lkml.org 
[lkml]   [2020]   [Feb]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 1/4] mtd: rawnand: Add support manufacturer specific lock/unlock operatoin
On Mon, 17 Feb 2020 10:01:24 +0100
Miquel Raynal <miquel.raynal@bootlin.com> wrote:

> Hi Mason,
>
> masonccyang@mxic.com.tw wrote on Mon, 17 Feb 2020 16:14:23 +0800:
>
> > Hi Boris,
> >
> > >
> > > > /* Set default functions */
> > > > static void nand_set_defaults(struct nand_chip *chip)
> > > > {
> > > > @@ -5782,8 +5810,8 @@ static int nand_scan_tail(struct nand_chip
> > *chip)
> > > > mtd->_read_oob = nand_read_oob;
> > > > mtd->_write_oob = nand_write_oob;
> > > > mtd->_sync = nand_sync;
> > > > - mtd->_lock = NULL;
> > > > - mtd->_unlock = NULL;
> > > > + mtd->_lock = nand_lock;
> > > > + mtd->_unlock = nand_unlock;
> > > > mtd->_suspend = nand_suspend;
> > > > mtd->_resume = nand_resume;
> > > > mtd->_reboot = nand_shutdown;
> > > > diff --git a/include/linux/mtd/rawnand.h b/include/linux/mtd/rawnand.h
> > > > index 4ab9bcc..2430ecd 100644
> > > > --- a/include/linux/mtd/rawnand.h
> > > > +++ b/include/linux/mtd/rawnand.h
> > > > @@ -1136,6 +1136,9 @@ struct nand_chip {
> > > > const struct nand_manufacturer *desc;
> > > > void *priv;
> > > > } manufacturer;
> > > > +
> > > > + int (*_lock)(struct nand_chip *chip, loff_t ofs, uint64_t len);
> > > > + int (*_unlock)(struct nand_chip *chip, loff_t ofs, uint64_t len);
> > >
> > > Please drop this _ prefix.
> >
> > Drop _ prefix of _lock will get compile error due to there is already
> > defined "struct mutex lock" in struct nand_chip.
>
> Right!

Or maybe move all hooks to a sub-struct (struct nand_chip_ops ops). I
had planned to do that in my nand_chip_legacy refactor but never did, so
maybe now is a good time.

>
> >
> > What about keep this _ prefix or patch it to blocklock/blockunlock,
> > i.e.,
> > int (*blocklock)(struct nand_chip *chip, loff_t ofs, uint64_t len);
> > int (*blockunlock)(struct nand_chip *chip, loff_t ofs, uint64_t len);
>
> What about lock_area() unlock_area() ? Seems more accurate to me, tell
> me if I'm wrong.

Yep, definitely better.

\
 
 \ /
  Last update: 2020-02-17 10:22    [W:0.068 / U:0.216 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site