lkml.org 
[lkml]   [2020]   [Nov]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v1 1/3] vt: keyboard, use GENMAASK()/BIT() macros instead of open coded variants
On Mon, Nov 9, 2020 at 11:57 AM Jiri Slaby <jirislaby@kernel.org> wrote:
> On 06. 11. 20, 17:06, Andy Shevchenko wrote:
> > On Fri, Nov 6, 2020 at 5:35 PM David Laight <David.Laight@aculab.com> wrote:
> >> From: Andy Shevchenko
> >>> Sent: 06 November 2020 14:36
> >>>
> >>> There are few places when GENMASK() or BIT() macro is suitable and makes code
> >>> easier to understand.

Thanks for the review, my answers below.

> >> ...
> >>> - if ((d & ~0xff) == BRL_UC_ROW) {
> >>> - if ((ch & ~0xff) == BRL_UC_ROW)
> >>> + if ((d & ~GENMASK(7, 0)) == BRL_UC_ROW) {
> >>> + if ((ch & ~GENMASK(7, 0)) == BRL_UC_ROW)
> >>> return d | ch;
> >>
> >> Do you really think that makes it more readable?
> >
> > Yes. Because this tells explicitly how many bits are used for metadata
> > vs. data.
>
> No, because ~0xff is clearly what it is. GENMASK(7, 0) is:
> 1) longer to read & parse by brain with result: "GENMASK undefined"
> 2) terrible in this particular use case

Maybe #define with a proper name can bring some shed of light here?

> Another instance of an even worse switch:
> - if (arg & ~0x77)
> + if (arg & ~(GENMASK(6, 4) | GENMASK(2, 0)))

It exactly shows what bits we are accepting and what are not. 0x77 you
need to translate to the bitmap and then figure out the bit numbers.
This is error prone as shown in some cases.

> OTOH, the switch to BIT is legit in all cases except the comparisons
> with keycode:
> - if (keycode > 127)
> + if (keycode >= BIT(7))
> - if (keycode < 128) {
> + if (keycode < BIT(7)) {
>
> That's horrid and non-sense too.

Isn't it the exact threshold about keycodes that we only use 7-bit value?

> sorry,

Consider this then as RFC.
What about the rest of the series?


--
With Best Regards,
Andy Shevchenko

\
 
 \ /
  Last update: 2020-11-09 11:10    [W:0.070 / U:0.252 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site