lkml.org 
[lkml]   [2020]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 32/32] auxdisplay: lcd2s DT binding doc
On Tue, Sep 22, 2020 at 09:58:36AM -0600, Rob Herring wrote:
> On Mon, 21 Sep 2020 16:46:44 +0200, poeschel@lemonage.de wrote:
> > From: Lars Poeschel <poeschel@lemonage.de>
> >
> > Add a binding doc for the modtronix lcd2s auxdisplay driver. It also
> > adds modtronix to the list of known vendor-prefixes.
> >
> > Signed-off-by: Lars Poeschel <poeschel@lemonage.de>
> > --
> > Changes in v2:
> > - Adopted yaml based file format
> > ---
> > .../bindings/auxdisplay/modtronix,lcd2s.yaml | 55 +++++++++++++++++++
> > .../devicetree/bindings/vendor-prefixes.yaml | 2 +
> > 2 files changed, 57 insertions(+)
> > create mode 100644 Documentation/devicetree/bindings/auxdisplay/modtronix,lcd2s.yaml
> >
>
>
> My bot found errors running 'make dt_binding_check' on your patch:
>
> Traceback (most recent call last):
> File "/usr/local/bin/dt-extract-example", line 45, in <module>
> binding = yaml.load(open(args.yamlfile, encoding='utf-8').read())
> File "/usr/local/lib/python3.8/dist-packages/ruamel/yaml/main.py", line 343, in load
> return constructor.get_single_data()
> File "/usr/local/lib/python3.8/dist-packages/ruamel/yaml/constructor.py", line 111, in get_single_data
> node = self.composer.get_single_node()
> File "_ruamel_yaml.pyx", line 706, in _ruamel_yaml.CParser.get_single_node
> File "_ruamel_yaml.pyx", line 724, in _ruamel_yaml.CParser._compose_document
> File "_ruamel_yaml.pyx", line 775, in _ruamel_yaml.CParser._compose_node
> File "_ruamel_yaml.pyx", line 891, in _ruamel_yaml.CParser._compose_mapping_node
> File "_ruamel_yaml.pyx", line 904, in _ruamel_yaml.CParser._parse_next_event
> ruamel.yaml.parser.ParserError: while parsing a block mapping
> in "<unicode string>", line 4, column 1
> did not find expected key
> in "<unicode string>", line 55, column 1
> make[1]: *** [Documentation/devicetree/bindings/Makefile:18: Documentation/devicetree/bindings/auxdisplay/modtronix,lcd2s.example.dts] Error 1
> make[1]: *** Deleting file 'Documentation/devicetree/bindings/auxdisplay/modtronix,lcd2s.example.dts'
> make[1]: *** Waiting for unfinished jobs....
> ./Documentation/devicetree/bindings/auxdisplay/modtronix,lcd2s.yaml: while parsing a block mapping
> in "<unicode string>", line 4, column 1
> did not find expected key
> in "<unicode string>", line 55, column 1
> /builds/robherring/linux-dt-review/Documentation/devicetree/bindings/auxdisplay/modtronix,lcd2s.yaml: ignoring, error parsing file
> warning: no schema found in file: ./Documentation/devicetree/bindings/auxdisplay/modtronix,lcd2s.yaml
> make: *** [Makefile:1366: dt_binding_check] Error 2
>
>
> See https://patchwork.ozlabs.org/patch/1368465
>
> If you already ran 'make dt_binding_check' and didn't see the above
> error(s), then make sure dt-schema is up to date:
>
> pip3 install git+https://github.com/devicetree-org/dt-schema.git@master --upgrade
>
> Please check and re-submit.

To be honest: I have indeed problems running make dt_binding_check:

larsi@lem-wkst-02:~/projekte/linux-stable$ make dt_binding_check
ERROR: dtschema minimum version is v2020.5
make[1]: *** [Documentation/devicetree/bindings/Makefile:10: check_dtschema_version] Fehler 1
make: *** [Makefile:1366: dt_binding_check] Fehler 2

Well ok, I seem to have a problem with some version. I took a look at
the mentioned part of the Makefile and found, that a tool
dt-doc-validate is called with --version argument to find out if my
version suffices. So I tried that:

larsi@lem-wkst-02:~/projekte/linux-stable$ dt-doc-validate --version
2020.8.2.dev2+gd63b653

What is wrong ? Can you give me a hint how I can properly run these
checks ?

Thank you,
Lars

\
 
 \ /
  Last update: 2020-10-02 15:46    [W:0.065 / U:0.784 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site