lkml.org 
[lkml]   [2020]   [Oct]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH V7 4/5] platform/x86: Intel PMT Telemetry capability driver
On Thu, Oct 1, 2020 at 7:46 PM Alexander Duyck
<alexander.duyck@gmail.com> wrote:
> On Thu, Oct 1, 2020 at 9:03 AM Andy Shevchenko
> <andy.shevchenko@gmail.com> wrote:

> > > +static struct platform_driver pmt_telem_driver = {
> > > + .driver = {
> > > + .name = TELEM_DEV_NAME,
> >
> > I'm not sure I have interpreted this:
> > - Use 'raw' string instead of defines for device names
> > correctly. Can you elaborate?
>
> Can you point me to a reference of that? I'm not sure what you are referring to.

It's a changelog of this very series.

> > > + },
> > > + .remove = pmt_telem_remove,
> > > + .probe = pmt_telem_probe,
> > > +};
> >
> > ...
> >
> > > +MODULE_ALIAS("platform:" TELEM_DEV_NAME);
> >
> > Ditto.
>
> This doesn't make sense to me. Are you saying we are expected to use
> "pmt_telemetry" everywhere instead of the define? It seems like that
> would be much more error prone. It seems like common practice to use
> DRV_NAME throughout a driver for these sort of things so if you are
> wanting us to rename it to that I am fine with that, but I am not sure
> getting rid of the use of a define makes sense.

I'm just wondering why changelog mentioned that and what it meant.
If it's indeed conversion to explicit naming, then this has to be
followed (somebody seems asked for that, right?) or commented why not.
Or maybe I understood it wrong?

--
With Best Regards,
Andy Shevchenko

\
 
 \ /
  Last update: 2020-10-01 19:55    [W:0.057 / U:26.272 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site