lkml.org 
[lkml]   [2020]   [Jan]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v2 00/13] initramfs: a lot of cleanups
On Sun, Jan 5, 2020 at 12:03 AM Masahiro Yamada <masahiroy@kernel.org> wrote:
>
>
>
> Masahiro Yamada (13):
> initramfs: replace klibcdirs in Makefile with FORCE
> gen_initramfs_list.sh: remove unused variable 'default_list'
> gen_initramfs_list.sh: fix the tool name in the comment
> initramfs: rename gen_initramfs_list.sh to gen_initramfs.sh
> initramfs: remove redundant dependency on BLK_DEV_INITRD
> initramfs: make compression options not depend on INITRAMFS_SOURCE
> initramfs: make initramfs compression choice non-optional
> initramfs: specify $(src)/gen_initramfs.sh as a prerequisite in
> Makefile
> initramfs: generate dependency list and cpio at the same time
> initramfs: add default_cpio_list, and delete -d option support
> gen_initramfs.sh: always output cpio even without -o option
> initramfs: refactor the initramfs build rules
> gen_initramfs.sh: remove intermediate cpio_list on errors

All, applied to linux-kbuild.


> usr/.gitignore | 8 +-
> usr/Kconfig | 26 ---
> usr/Makefile | 97 ++++++----
> usr/default_cpio_list | 6 +
> ...gen_initramfs_list.sh => gen_initramfs.sh} | 167 +++++-------------
> usr/initramfs_data.S | 5 +-
> 6 files changed, 112 insertions(+), 197 deletions(-)
> create mode 100644 usr/default_cpio_list
> rename usr/{gen_initramfs_list.sh => gen_initramfs.sh} (53%)
>
> --
> 2.17.1
>


--
Best Regards
Masahiro Yamada

\
 
 \ /
  Last update: 2020-01-21 17:01    [W:0.223 / U:7.960 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site