lkml.org 
[lkml]   [2020]   [Jan]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[Patch v2 0/4] mm/page_alloc.c: cleanup on check page
Date
The patch set does some cleanup related to check page.

1. Enable passing all bad reason to __dump_page()
2. Extract common part to check page
3. Remove unnecessary bad_reason assignment

Thanks suggestions from David Rientjes.

v2:
* merge two rename patches into extract patch
* enable dump several reasons for __dump_page()

Wei Yang (4):
mm: enable dump several reasons for __dump_page()
mm/page_alloc.c: bad_[reason|flags] is not necessary when PageHWPoison
mm/page_alloc.c: pass all bad reasons to bad_page()
mm/page_alloc.c: extract commom part to check page

include/linux/mmdebug.h | 2 +-
mm/debug.c | 11 +++---
mm/page_alloc.c | 87 +++++++++++++++++++++--------------------
3 files changed, 51 insertions(+), 49 deletions(-)

--
2.17.1

\
 
 \ /
  Last update: 2020-01-20 04:05    [W:0.121 / U:0.092 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site