lkml.org 
[lkml]   [2020]   [Jan]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] iommu/qcom: fix NULL pointer dereference during probe deferral
On Tue, Dec 31, 2019 at 10:39:49PM -0500, Brian Masney wrote:
[...]
> (kernel_init) from ret_from_fork (arch/arm/kernel/entry-common.S:156)
> Exception stack(0xee89dfb0 to 0xee89dff8)
> dfa0: 00000000 00000000 00000000 00000000
> dfc0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
> dfe0: 00000000 00000000 00000000 00000000 00000013 00000000
> Code: e92d4070 e1a04000 e3a01004 e240501c (e5930014)

This looks like ARM code...

> All code
> ========
> 0: 70 40 jo 0x42
> 2: 2d e9 00 40 a0 sub $0xa04000e9,%eax
> 7: e1 04 loope 0xd
> 9: 10 a0 e3 1c 50 40 adc %ah,0x40501ce3(%rax)
> f: e2 14 loop 0x25
> 11:* 00 .byte 0x0 <-- trapping instruction
> 12: 93 xchg %eax,%ebx
> 13: e5 .byte 0xe5

... disassembled as x86 code.

I suspect that scripts/decodecode picked up the wrong architecture
somehow. Perhaps CROSS_COMPILE wasn't set?

>
> Code starting with the faulting instruction
> ===========================================
> 0: 14 00 adc $0x0,%al
> 2: 93 xchg %eax,%ebx
> 3: e5 .byte 0xe5


Greetings and a happy new year,
Jonathan Neuschäfer
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2020-01-01 19:20    [W:0.069 / U:32.964 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site