lkml.org 
[lkml]   [2019]   [Sep]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 5/7] lib: rework bitmap_parse()
On Sun, Sep 08, 2019 at 08:30:19PM -0700, Yury Norov wrote:
> bitmap_parse() is ineffective and full of opaque variables and opencoded
> parts. It leads to hard understanding and usage of it. This rework
> includes:
> - remove bitmap_shift_left() call from the cycle. Now it makes the
> complexity of the algorithm as O(nbits^2). In the suggested approach
> the input string is parsed in reverse direction, so no shifts needed;
> - relax requirement on a single comma and no white spaces between chunks.
> It is considered useful in scripting, and it aligns with
> bitmap_parselist();
> - split bitmap_parse() to small readable helpers;
> - make an explicit calculation of the end of input line at the
> beginning, so users of the bitmap_parse() won't bother doing this.

> +static const char *bitmap_get_x32_reverse(const char *start,
> + const char *end, u32 *num)
> +{
> + u32 ret = 0;
> + int c, i;
> +

> + if (!isxdigit(*end))
> + return ERR_PTR(-EINVAL);

This seems redundant...

> +
> + for (i = 0; i < 32; i += 4) {

> + c = hex_to_bin(*end--);
> + if (c < 0)
> + return ERR_PTR(-EINVAL);

...because this will do the same check.

Am I right?

> +
> + ret |= c << i;
> +
> + if (start > end || __end_of_region(*end))
> + goto out;
> + }
> +

> + if (isxdigit(*end))
> + return ERR_PTR(-EOVERFLOW);

hex_to_bin() doesn't rely on ctype array, won't drain caches.
I guess it's not a fast path, so, either will work.

> +out:
> + *num = ret;
> + return end;
> +}

--
With Best Regards,
Andy Shevchenko


\
 
 \ /
  Last update: 2019-09-09 12:07    [W:0.050 / U:0.116 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site