lkml.org 
[lkml]   [2019]   [Aug]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 4/9] drm: meson: vpp: use proper macros instead of magic constants
From
Date
On 25/06/2019 01:15, Kevin Hilman wrote:
> Julien Masson <jmasson@baylibre.com> writes:
>
>> This patch add new macros which are used to set the following
>> registers:
>> - VPP_OSD_SCALE_COEF_IDX
>> - VPP_DOLBY_CTRL
>> - VPP_OFIFO_SIZE
>> - VPP_HOLD_LINES
>> - VPP_SC_MISC
>> - VPP_VADJ_CTRL
>>
>> Signed-off-by: Julien Masson <jmasson@baylibre.com>
>
> [...]
>
>> @@ -97,20 +97,22 @@ void meson_vpp_init(struct meson_drm *priv)
>> else if (meson_vpu_is_compatible(priv, "amlogic,meson-gxm-vpu")) {
>> writel_bits_relaxed(0xff << 16, 0xff << 16,
>> priv->io_base + _REG(VIU_MISC_CTRL1));
>> - writel_relaxed(0x20000, priv->io_base + _REG(VPP_DOLBY_CTRL));
>> - writel_relaxed(0x1020080,
>> + writel_relaxed(VPP_PPS_DUMMY_DATA_MODE,
>> + priv->io_base + _REG(VPP_DOLBY_CTRL));
>> + writel_relaxed(0x108080,
>
> nit: still a magic constant here, and it's not obvious why it's
> different from the current one.

This is a magic constant, it's a color, but indeed it should not change.

0x1020080 is the 10bit variant of 0x108080, on purpose.

Neil

>
> Kevin
>

\
 
 \ /
  Last update: 2019-08-08 16:10    [W:0.049 / U:1.324 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site