[lkml]   [2019]   [Aug]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] m68k: atari: Rename shifter to shifter_st to avoid conflict
On Mon, Aug 12, 2019 at 9:30 AM Geert Uytterhoeven <> wrote:

> When test-compiling the BCM2835 pin control driver on m68k:
> In file included from arch/m68k/include/asm/io_mm.h:32:0,
> from arch/m68k/include/asm/io.h:8,
> from include/linux/io.h:13,
> from include/linux/irq.h:20,
> from include/linux/gpio/driver.h:7,
> from drivers/pinctrl/bcm/pinctrl-bcm2835.c:17:
> drivers/pinctrl/bcm/pinctrl-bcm2835.c: In function 'bcm2711_pull_config_set':
> arch/m68k/include/asm/atarihw.h:190:22: error: expected identifier or '(' before 'volatile'
> # define shifter ((*(volatile struct SHIFTER *)SHF_BAS))
> "shifter" is a too generic name for a global definition.
> As the corresponding definition for Atari TT is already called
> "shifter_tt", fix this by renaming the definition for Atari ST to
> "shifter_st".
> Reported-by: kbuild test robot <>
> Suggested-by: Michael Schmitz <>
> Signed-off-by: Geert Uytterhoeven <>

Finally we can use the sh pfc pin controller on our m68k Atari.

Now if I can only resolder the capacitors on my Atari TT ST
before the board self-destructs I will one day test this.

Reviewed-by: Linus Walleij <>

Linus Walleij

 \ /
  Last update: 2019-08-14 10:29    [W:0.028 / U:3.284 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site