lkml.org 
[lkml]   [2019]   [Jul]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH B] scsi: fdomain: fix building pcmcia front-end
Date
We get a warning when CONFIG_SCSI_LOWLEVEL is disabled here:

WARNING: unmet direct dependencies detected for SCSI_FDOMAIN
Depends on [n]: SCSI_LOWLEVEL [=n] && SCSI [=y]
Selected by [m]:
- PCMCIA_FDOMAIN [=m] && SCSI_LOWLEVEL_PCMCIA [=y] && SCSI [=y] && PCMCIA [=y] && m && MODULES [=y]

Move all of SCSI_LOWLEVEL_PCMCIA inside of the existing
SCSI_LOWLEVEL section. Very few people use the PCMCIA support
these days, and they likely don't mind having to turn on
SCSI_LOWLEVEL as well. This way we avoid the link error
and get a more sensible structure.

Fixes: 7d47fa065e62 ("scsi: fdomain: Add PCMCIA support")
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
---
One of two ways to fix the problem, please pick either

drivers/scsi/Kconfig | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/scsi/Kconfig b/drivers/scsi/Kconfig
index 75f66f8ad3ea..1b92f3c19ff3 100644
--- a/drivers/scsi/Kconfig
+++ b/drivers/scsi/Kconfig
@@ -1523,10 +1523,10 @@ config SCSI_VIRTIO

source "drivers/scsi/csiostor/Kconfig"

-endif # SCSI_LOWLEVEL
-
source "drivers/scsi/pcmcia/Kconfig"

+endif # SCSI_LOWLEVEL
+
source "drivers/scsi/device_handler/Kconfig"

endmenu
--
2.20.0
\
 
 \ /
  Last update: 2019-07-22 14:20    [W:0.035 / U:8.128 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site