lkml.org 
[lkml]   [2019]   [Jul]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: leds: apu: drop obsolete support for apu>=2
From
Date
Hi Enrico,

Thank you for the patch set.

On 7/15/19 4:57 PM, Enrico Weigelt, metux IT consult wrote:
> Hi folks,
>
>
> the legacy apu LEDs driver has been superseded by the more complete
> pcengines-apu2 platform driver, for APU >= 2. It only supports
> the three front LEDs, but lacks all the other GPIOs (eg. button
> or simsw), and conflicts with the pcengines-apu2 driver.
>
> Old APUv1 has a very different chipset.
>
> Therefore I propose dropping the apu>=2 support from the legacy
> driver, reducing it to only the old (obsolete) APUv1 boards.


Patch set applied along with the update for the patch 5/6.

--
Best regards,
Jacek Anaszewski

\
 
 \ /
  Last update: 2019-07-22 22:12    [W:0.161 / U:1.252 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site