[lkml]   [2019]   [Jul]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] treewide: Rename rcu_dereference_raw_notrace to _check
On Thu, Jul 11, 2019 at 4:45 PM Joel Fernandes (Google)
<> wrote:
> The rcu_dereference_raw_notrace() API name is confusing.
> It is equivalent to rcu_dereference_raw() except that it also does
> sparse pointer checking.
> There are only a few users of rcu_dereference_raw_notrace(). This
> patches renames all of them to be rcu_dereference_raw_check with the
> "check" indicating sparse checking.
> Signed-off-by: Joel Fernandes (Google) <>

There also these _notrace things but I am Ok with leaving them alone for now:

- Joel

 \ /
  Last update: 2019-07-11 22:51    [W:0.027 / U:0.264 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site