lkml.org 
[lkml]   [2019]   [Jun]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject5.2-rc2: low framerate in flightgear, cpu not running at full speed, thermal related?
Hi!

When I start flightgear, I get framerates around 20 fps and cpu at
3GHz:

pavel@duo:~/bt$ cat /proc/cpuinfo | grep MHz
cpu MHz : 3027.471
cpu MHz : 2981.863
cpu MHz : 2958.352
cpu MHz : 2864.001
pavel@duo:~/bt$

(Ok, fgfs is really only running at single core, so why do both cores
run at 3GHz?)

But temperatures get quite high:

pavel@duo:~/bt$ sensors
thinkpad-isa-0000
Adapter: ISA adapter
fan1: 4485 RPM

coretemp-isa-0000
Adapter: ISA adapter
Package id 0: +98.0°C (high = +86.0°C, crit = +100.0°C)
Core 0: +98.0°C (high = +86.0°C, crit = +100.0°C)
Core 1: +91.0°C (high = +86.0°C, crit = +100.0°C)

And soon cpu goes to 1.5GHz range, with framerates going down to
12fps. That's a bit low.

Room temperature is 26Celsius.

The CPU is Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz . I guess it means
it should be able to sustain both cores running at 2.5GHz?

Any ideas? Were there any recent changes in that area?

Best regards,
Pavel

--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2019-06-09 13:18    [W:0.143 / U:6.300 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site