lkml.org 
[lkml]   [2019]   [Jun]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [5.2.0-rcx] Bluetooth: hci0: unexpected event for opcode
Am Do., 6. Juni 2019 um 08:18 Uhr schrieb Marcel Holtmann <marcel@holtmann.org>:
>
> Hi Joerg,
>
> > In 5.2.0-rcx I see a new error message on startup probably after
> > loading the Bluetooth firmware:
> > [ 1.609460] Bluetooth: hci0: unexpected event for opcode 0xfc2f
> >
> >> dmesg | grep Bluetooth
> > [ 0.130969] Bluetooth: Core ver 2.22
> > [ 0.130973] Bluetooth: HCI device and connection manager initialized
> > [ 0.130974] Bluetooth: HCI socket layer initialized
> > [ 0.130975] Bluetooth: L2CAP socket layer initialized
> > [ 0.130976] Bluetooth: SCO socket layer initialized
> > [ 0.374716] Bluetooth: RFCOMM TTY layer initialized
> > [ 0.374718] Bluetooth: RFCOMM socket layer initialized
> > [ 0.374718] Bluetooth: RFCOMM ver 1.11
> > [ 0.374719] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
> > [ 0.374720] Bluetooth: BNEP socket layer initialized
> > [ 0.374721] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
> > [ 0.374722] Bluetooth: HIDP socket layer initialized
> > [ 1.422530] Bluetooth: hci0: read Intel version: 370710018002030d00
> > [ 1.422533] Bluetooth: hci0: Intel Bluetooth firmware file:
> > intel/ibt-hw-37.7.10-fw-1.80.2.3.d.bseq
> > [ 1.609460] Bluetooth: hci0: unexpected event for opcode 0xfc2f
> > [ 1.625557] Bluetooth: hci0: Intel firmware patch completed and activated
> > [ 21.986125] input: BluetoothMouse3600 Mouse as
> > /devices/virtual/misc/uhid/0005:045E:0916.0004/input/input15
> > [ 21.986329] input: BluetoothMouse3600 Consumer Control as
> > /devices/virtual/misc/uhid/0005:045E:0916.0004/input/input16
> > [ 21.986408] hid-generic 0005:045E:0916.0004: input,hidraw3:
> > BLUETOOTH HID v1.10 Mouse [BluetoothMouse3600] on 80:19:34:4D:31:44
> >
> >
> > The error message goes away if I revert following patch:
> > f80c5dad7b64 Bluetooth: Ignore CC events not matching the last HCI command
>
> if you can send btmon trace (or better btmon -w trace.log) for this event triggering it, then we can look if this is a hardware issue.

The problem is that it happens only once during startup, especially at
the very first startup after power-on only. So I can't issue any
command.

>We have only seen this with Atheros hardware so far, but it might happen for others as well. It indicates that this is an unexpected event. Normally you can ignore this warning since it just indicates an existing issue that we just papered over before. So if everything works as before, just ignore it,

Yes for me BT works as usual so ignoring it would be no problem (but
it looks ugly because the error message is painted right on the
boot-screen).

Thanks, Jörg

\
 
 \ /
  Last update: 2019-06-06 12:38    [W:0.075 / U:0.080 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site