lkml.org 
[lkml]   [2019]   [Jun]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: PREEMPT_RT_FULL on x86-32 machine
On 2019-06-24 12:53:40 [+0200], Pavel Machek wrote:
> Hi!
Hi,

> > >Is full preemption supposed to work on x86-32 machines?
> > >
> > >Because it does not work for me. It crashes early in boot, no messages
> > >make it to console. Similar configuration for x86-64 boots ok.
> > >
> >
> > Maybe you can also tell which version(s) you tried, and in which
> > configuration(s), and how the crash looked like.
>
> I wanted to know if the configuration is supposed to work at all
> before starting heavy debugging. From your reply I assume that it
> should work.
>
> I tried 4.19.13-rt1-cip1 among others. Crash is early in boot, I can
> try some early printing...

The latest is v4.19.50-rt22 I would suggest that one. There was a bug
which was fixed either in 4.19.23-rt14 or in the following version.

If the latest one does not work please let me know and I will have a
look.

> Best regards,
> Pavel

Sebastian

\
 
 \ /
  Last update: 2019-06-24 15:28    [W:0.087 / U:3.020 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site