lkml.org 
[lkml]   [2019]   [Jun]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectmsm8996: qcom-qmp: apq8096-db820c fails to boot, reset back to fastboot and locks up
From time to time, my apq8096-db820c fails to boot to userspace, reset back to
fastboot and locks up: to easily reproduce the issue, i'm boot looping using a
cron job with a 1 min reboot entry on the board while leaving a "while 1; do
fastboot boot boot.img; done" on the host pc.

The issue is present in mainline up to 5.2-rc4, using defconfig and:

CONFIG_SCSI_UFS_QCOM=y
CONFIG_PHY_QCOM_QMP=y
CONFIG_PHY_QCOM_UFS=y

but was present in previous releases too (e.g. 4.14., 4.19, etc qcom-lt or
mainline), where it's even easier to reproduce (e.g. takes way less reboots to
trigger it).

These are the last lines printed out:
...
[ 7.407209] qcom-qmp-phy 34000.phy: Registered Qcom-QMP phy
[ 7.448058] qcom-qmp-phy 7410000.phy: Registered Qcom-QMP phy
[ 7.461859] ufs_qcom_phy_qmp_14nm 627000.phy: invalid resource
[ 7.535434] qcom-qmp-phy 34000.phy: phy common block init timed-out
[ 7.538596] phy phy-34000.phy.0: phy init failed --> -110
[ 7.550891] qcom-pcie: probe of 600000.pcie failed with error -110
[ 7.619008] qcom-pcie 608000.pcie: 608000.pcie supply vddpe-3v3 not found,
using dummy regulator

Log Type: B - Since Boot(Power On Reset), D - Delta, S - Statistic
S - QC_IMAGE_VERSION_STRING=BOOT.XF.1.0-00301
S - IMAGE_VARIANT_STRING=M8996LAB
S - OEM_IMAGE_VERSION_STRING=crm-ubuntu68
S - Boot Interface: UFS
S - Secure Boot: Off
...

Full boot here: https://pastebin.ubuntu.com/p/rtjVrD3yzk/

Any idea what is going on? Am i doing something wrong?
--
bye,
p.

\
 
 \ /
  Last update: 2019-06-10 15:44    [W:0.058 / U:42.248 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site