lkml.org 
[lkml]   [2019]   [Jun]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v6 01/19] kernel: Standardize vdso_datapage
From
Date
Hi Huw,

thank you for your review.

On 10/06/2019 10:27, Huw Davies wrote:
> On Thu, May 30, 2019 at 03:15:13PM +0100, Vincenzo Frascino wrote:
>> --- /dev/null
>> +++ b/include/vdso/datapage.h
>> @@ -0,0 +1,91 @@
>> +/* SPDX-License-Identifier: GPL-2.0 */
>> +#ifndef __VDSO_DATAPAGE_H
>> +#define __VDSO_DATAPAGE_H
>> +
>> +#ifdef __KERNEL__
>> +
>> +#ifndef __ASSEMBLY__
>> +
>> +#include <linux/bits.h>
>> +#include <linux/time.h>
>> +#include <linux/types.h>
>> +
>> +#define VDSO_BASES (CLOCK_TAI + 1)
>> +#define VDSO_HRES (BIT(CLOCK_REALTIME) | \
>> + BIT(CLOCK_MONOTONIC) | \
>> + BIT(CLOCK_BOOTTIME) | \
>> + BIT(CLOCK_TAI))
>> +#define VDSO_COARSE (BIT(CLOCK_REALTIME_COARSE) | \
>> + BIT(CLOCK_MONOTONIC_COARSE))
>> +#define VDSO_RAW (BIT(CLOCK_MONOTONIC_RAW))
>> +
>> +#define CS_HRES_COARSE 0
>> +#define CS_RAW 1
>
> CS_HRES_COARSE seems like a confusing name choice to me. What you
> really mean is not RAW.
>
> How about CS_ADJ to indicate that its updated by adjtime?
> CS_XTIME might be another option.
>

I divided the timers in 3 sets (HRES, COARSE, RAW), CS_HRES_COARSE refers to the
first two and CS_RAW to the third. I will ad a comment to explain the logic in
the next iteration.

> Huw.
>

--
Regards,
Vincenzo

\
 
 \ /
  Last update: 2019-06-10 12:18    [W:0.417 / U:0.288 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site