lkml.org 
[lkml]   [2019]   [Apr]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v5 1/7] dt-bindings: Add panel-timing subnode to simple-panel
Thierry,

On Mon, Apr 8, 2019 at 3:32 AM Thierry Reding <thierry.reding@gmail.com> wrote:
>
> On Mon, Apr 01, 2019 at 10:17:18AM -0700, Douglas Anderson wrote:
> > From: Sean Paul <seanpaul@chromium.org>
> >
> > This patch adds a new subnode to simple-panel allowing us to override
> > the typical timing expressed in the panel's display_timing.
> >
> > Changes in v2:
> > - Split out the binding into a new patch (Rob)
> > - display-timings is a new section (Rob)
> > - Use the full display-timings subnode instead of picking the timing
> > out (Rob/Thierry)
> > Changes in v3:
> > - Go back to using the timing subnode directly, but rename to
> > panel-timing (Rob)
> > Changes in v4:
> > - Simplify desc. for when override should be used (Thierry/Laurent)
> > - Removed Rob H review since it's been a year and wording changed
> > Changes in v5:
> > - Removed bit about OS may ignore (Rob/Ezequiel)
> >
> > Cc: Doug Anderson <dianders@chromium.org>
> > Cc: Eric Anholt <eric@anholt.net>
> > Cc: Heiko Stuebner <heiko@sntech.de>
> > Cc: Jeffy Chen <jeffy.chen@rock-chips.com>
> > Cc: Rob Herring <robh+dt@kernel.org>
> > Cc: Stéphane Marchesin <marcheu@chromium.org>
> > Cc: Thierry Reding <thierry.reding@gmail.com>
> > Cc: devicetree@vger.kernel.org
> > Cc: dri-devel@lists.freedesktop.org
> > Cc: linux-rockchip@lists.infradead.org
> > Signed-off-by: Sean Paul <seanpaul@chromium.org>
> > Signed-off-by: Douglas Anderson <dianders@chromium.org>
> > ---
> >
> > .../bindings/display/panel/simple-panel.txt | 22 +++++++++++++++++++
> > 1 file changed, 22 insertions(+)
> >
> > diff --git a/Documentation/devicetree/bindings/display/panel/simple-panel.txt b/Documentation/devicetree/bindings/display/panel/simple-panel.txt
> > index b2b872c710f2..93882268c0b9 100644
> > --- a/Documentation/devicetree/bindings/display/panel/simple-panel.txt
> > +++ b/Documentation/devicetree/bindings/display/panel/simple-panel.txt
> > @@ -15,6 +15,16 @@ Optional properties:
> > (hot plug detect) signal, but the signal isn't hooked up so we should
> > hardcode the max delay from the panel spec when powering up the panel.
> >
> > +panel-timing subnode
>
> Is there any reason why we need the panel- prefix? This is already part
> of a panel definition, so it's completely redundant. Why not just name
> the subnode "timing"?

It was a really long time ago since this patch series was idle for a
while, but you previous had similar feedback in v3 but ended up OK
with it. See:

https://patchwork.kernel.org/patch/10207583/

I believe the original node name came out of some back and forth
between Rob and Sean. As far as I can tell, the context is back in
<https://patchwork.kernel.org/patch/10203483/>. I think Rob wanted it
to follow other similar node names.


That all being said, if you feel strongly about it being called
"timing" and Rob's OK w/ that too then I'll re-spin the series.

-Doug

\
 
 \ /
  Last update: 2019-04-08 16:47    [W:0.063 / U:0.008 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site