lkml.org 
[lkml]   [2019]   [Apr]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] overflow.h: Rename __ab_c_size() to __calc_size()
From
Date
On 05/04/2019 06.57, Borislav Petkov wrote:
> From: Borislav Petkov <bp@suse.de>
>
> ... to make its name readable to humans so that it can denote what that helper does.

I like the current color. It computes a*b+c with overflow checking at each step. calc_size is
way too generic and doesn't say anything at all about how the calc(ulation) is done.

Rasmus

\
 
 \ /
  Last update: 2019-04-05 08:27    [W:0.065 / U:4.356 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site