lkml.org 
[lkml]   [2019]   [Apr]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH net-next 16/19] net: ethernet: ti: cpsw: move common hw init code in separate func
From
Date


On 25.04.19 16:38, Murali Karicheri wrote:
> On 04/23/2019 09:09 AM, Grygorii Strashko wrote:
>> move common hw init code in separate function as preparation for adding new
>> switchdev driver.
> All of the changes indicates a better name for the file is cpsw_common.c; commit log,
new function cpsw_init_common() etc. Any specific reason to use cpsw_priv.[ch]?

I've been thinking about this, but cpsw_coomon.c is used by davinici_emac also.
More over, I have a hope that it'd be possible to get rid of cpsw_common.c at all
by switching to nvmem.

Also, I'd be very appreciated if you'd be able to cut your replies.
It's a little bit hard to find your comments

>
>>
>> Signed-off-by: Grygorii Strashko <grygorii.strashko@ti.com>
>> ---
>>   drivers/net/ethernet/ti/Makefile    |   2 +-
>>   drivers/net/ethernet/ti/cpsw.c      | 106 ++---------------------
>>   drivers/net/ethernet/ti/cpsw_priv.c | 128 ++++++++++++++++++++++++++++
>>   drivers/net/ethernet/ti/cpsw_priv.h |   3 +
>>   4 files changed, 137 insertions(+), 102 deletions(-)
>>   create mode 100644 drivers/net/ethernet/ti/cpsw_priv.c
>>
>> diff --git a/drivers/net/ethernet/ti/Makefile b/drivers/net/ethernet/ti/Makefile
>> index 2f159a71f88e..de1561596646 100644
...

--
Best regards,
grygorii

\
 
 \ /
  Last update: 2019-04-25 16:15    [W:0.072 / U:12.800 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site