lkml.org 
[lkml]   [2019]   [Apr]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH v2 RFC/RFT 1/5] ARM: dma-mapping: Add fallback normal page allocations
    Hi Christoph,

    On Wed, Apr 24, 2019 at 05:06:38PM +0200, Christoph Hellwig wrote:
    > On Tue, Mar 26, 2019 at 04:01:27PM -0700, Nicolin Chen wrote:
    > > page = dma_alloc_from_contiguous(dev, count, order, gfp & __GFP_NOWARN);
    > > + if (!page)
    > > + page = alloc_pages(gfp, order);
    >
    > We have this fallback in most callers already. And with me adding
    > it to the dma-iommu code in one series, and you to arm here I think
    > we really need to take a step back and think of a better way
    > to handle this, and the general mess that dma_alloc_from_contiguous.
    >
    > So what about:

    Thanks for the suggestion!

    > (1) change the dma_alloc_from_contiguous prototype to be:
    >
    > struct page *dma_alloc_contiguous(struct device *dev, size_t size, gfp_t gfp);
    >
    > that is: calculate order and count internally, pass the full gfp_t
    > and mask it internally, and drop the pointless from in the name.
    > I'd also use the oppurtunity to forbid a NULL dev argument and
    > opencode those uses.
    >
    > (2) handle the alloc_pages fallback internally. Note that we should
    > use alloc_pages_node as we do in dma-direct.

    I feel it's similar to my previous set, which did most of these
    internally except the renaming part. But Catalin had a concern
    that some platforms might have limits on CMA range [1]. Will it
    be still okay to do the fallback internally?

    [1: https://www.spinics.net/lists/arm-kernel/msg714295.html ]

    \
     
     \ /
      Last update: 2019-04-24 20:33    [W:3.169 / U:0.020 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site